CCIE? Attitude Can Be Everything!

Are you thinking about a lofty certification like CCIE? In this series of posts, I am going to cover the awesome e-book from CBT Nuggets on how to succeed with online training.

https://s3.amazonaws.com/cbtnuggets-marketing/pdf/Online-Training-ebook.pdf

But I will be covering this text with a slant on one of our favorite topics here at AJS Networking – the Cisco Certified Internetwork Expert cert!

The first thing I really want you to focus on is your attitude about the whole thing. Here is the deal – it just HAS to be positive. Pretty darn positive most of the time. You are going to be practicing and studying so much, with basically yourself to account to, that is really possible you could throw up your hands and just ditch the whole idea.

Maybe we hit some topics that are vey difficult. Maybe several of our practice sessions seem like a waste of time. Maybe we even experience a NOT PASS in an actual attempt at the exam.

We have to work through these obstacles mentally and keep that incredibly positive attitude. Remember – you really love practicing this stuff and mastering it. You most likely got hooked on the whole concept when you crushed CCENT, then CCNA, then your CCNP.

I would suggest you revisit your RPM (thanks Tony Robbins).

What is it that you Really want? CCIE of course!

What is your Purpose in achieving it? Why do you really want it? List these out – I came up with about 8 reasons for the CCIE Security pursuit.

What is you Massive action plan to get there? Sure – there are a ton of steps, but remember, you LOVE this stuff.

I know that the pursuit can be a lonely one. As a people person (big time), I often feel that loneliness, especially since my family thinks the ASA stands for the American Sailing Association. Please use this blog to connect with me and others that are in this pursuit right along with you.

Tonight I am picking up my instructor from his long flight from Mumbai. That’s right – Rohit Pardasani right here in Tampa, Florida. He is on his way to instruct in Mexico. I will be sure to shoot some video for his guidance on his unstoppable passion, his incredibly positive attitude, that has helped him achieve 4 CCIEs, including the brutally difficult Voice CCIE.

How are you feeling about your CCIE pursuit? Let me know in the comments below!

download

 

37 thoughts on “CCIE? Attitude Can Be Everything!

  1. Hi Anthony,

    I just finished ur series on CCDA at CBT and about to take my exam this week. After this exam I a little torn between taking the ARCH exam to get my CCDP or just go ahead and start my CCIE R&S journey.

    I am unsure weather to take small steps like taking CCNA/NP collaboration and data center just to ease my training towards getting an IE or just go for it.

    1. If you are interested in R&S CCIE – then you should consider CCNA and CCNP R&S – those are the appropriate small steps. If you have those done – then begin your journey!

  2. Hi Anthony,

    I am on my persuit to CCIE R&S and started on March, 24.
    I have ready both the Official Books and it was not easy.
    Most of the time, it looks like I am the only one who understands what I want to achieve and people call me “crazy”.

    But, because I need it and I have time to study for it, I am not stopping until I get my NUMBER.

    Appreciate your Help.

    Best regards

    1. Yes – there are a ton of people that will say things like – “it is not worth it”, “the ccie is worthless now”, and other statements like this. This is almost always the case of someone that gave up on it themselves and they are now bitter.

  3. Hi,
    i have got my CCNP Routing and switching before 3 months, now i started to prepare to my CCIE R/S, i feel some difficulty since there is many books to go through and videos, so i decided to stop the videos that i started my study with, and begin the workbooks instead, by this way i felt better absorbing the new technologies and preparing me to go through the videos later on, then finally the books….i really started loving the networking more than before when i started CCNA…CCIE is the best

    1. Yes – the command line is the most rewarding – and it is critical that you have a ton of experience there – so great job!!!

  4. Dear Anthony,
    I hope everything is OK. I am writing you this message in order to guide me in my education.
    Recently, I drew myself a road map in which I want to participate in Cisco exams step by step. I want to take part in all CCNA exams, then CCNP exams, and the all CCIE exams. Since CCIE have no prerequisite, I can participate in CCIE exam directly. So if you were in my shoes, which way did you choose?

    Best Regards

    1. I would focus on every exam in depth and go step by step! So – start with the ICND1 exam. In fact – if you are very fresh with networking, you might even want to consider starting with Network+. Get excited for this journey – I am here to help along with all of my other readers!

    2. Peyman,

      I totally agree with Anthony that you need to follow the track, step by step… simply because jumping into the CCIE without foundation knowledge will overwhelm and take the excitement out of learning routing and switching. Unless you have considerable experience, you will find yourself going back to the basic info. That from my experience will bore and it will seem insurmountable.

      I made that mistake and hence it has taken me so long, with certifications expiring along the way.

  5. Hi Anthony,

    I must say that the education realm, and the world as a whole is a better place with people like yourself, who do not mind sharing what they know with the masses of interested people (I am sure you can recall some engineer, who would never share anything they knew but would rather do it themselves and not explain what and why they did it that way).

    I have been on the CCIE journey, as I call it Mt. Everest, for quite time now, but this year I finally made a decision that I would conquer my Mt. Everest. Right now, I can say that all I have are just bits and pieces by that I mean…. I can lab complex sections of OSPF, BGP, MPLS, DMVPN, redistribute and filter routes… but I lack in putting it all together, as in having a simulated topology of an actual working enterprise. I think that my other stumbling point is the way that some labs are worded, (sorry, at this time, I cannot think of a particular lab wording to use as an example).

    Thank you for this article, and all your other articles and enthusiasm as you teach and share the knowledge that you have, it is encouraging… and I promise you, I will stay on this course, until I reach the mountaintop.

    1. Hi Phillip!

      Do not stress too badly about putting it all together. Remember, the CCIE Lab Exam has you build a TERRIBLE network. You would never actually build such a thing. Multiple virtual links, protocols with clear text authentication, etc, etc. It is an ACADEMIC exercise that is meant to test you on SOME current tech, but certainly not in a manner that reflects an actual current enterprise network.

      1. Thank you for your response, it is immensely appreciated.

        When you have some time, is it possible that you can share your experiences as far as interviewing for jobs, as in how you prepared, what that experience was like… I ask because I am anticipating some interviews with Cisco and it would really help and put me at ease as to what’s to be expected.

        Sorry, if I am taking too much of your time.

  6. Hi Phillip! Perhaps other readers here can help out in this area. I am always recruited – I never really have to interview. 🙂

    I know, I know, I am very blessed.

    🙂

    1. ” I am always recruited – I never really have to interview.”

      If I am not inspired by that statement, nothing else will inspire me.

      Thank you for that, you have given me something to aspire to.

  7. I want to give my CCIE in Service provider, please guide me how to proceed further on this. As I know we have to give lot of time for this however, as I am a working professional I am unable to do that.

    Appreciate if you can be my mentor and guide me to achieve it.

    Thanks in Advance.

    1. For CCIE Service Provider, you can plan on around 700 hours or so of practice on the command line in order to be ready. Do you think you can start working those hours into your schedule?

  8. Hi Anthony
    I am still working on CCIE. I spent 4 hours everyday except the weekend (weekend for fun) and am sure I can do it from the first time (when God willing) .
    Who know may I become instructor in Cbtnuggets lol.
    Waiting for videos about his advices
    Thanks

  9. Hi Anthony,

    Please guide me, I got my CCIE(R&S) written exam in January and planning to take my lab exam in November.

    What can I get for preparations besides reading the books, watching the videos and of course practicing as I am doing that already?

    What strategy to use?
    At the moment I dedicate 4 hours per day for my studies.
    Is 4 hours too little for November exam?

    Thank u

    Kuts

    1. You are going to need about 700 hours of practice (on average). This will include practicing the individual blueprint technologies – for example – L3 MPLS VPN – and should also include some full lab practice. NetMasterClass features amazing graded labs – including an inexpensive $99 pre-assessment lab!

  10. Hello,
    I’m having an unfamiliar situation and I need your expert advice. I have a router a switch and ASA on a vlan with svi configured. I’m routing the VLANs on the switch to the ASA using ospf. The issue is that the switch and the ASA for neighbors with full adjacency but I can’t see the vlan subnets on the ASA I.e they don’t exchange routes even though I have advertised the network. Is there any thing I am doing wrongly?

    1. What you have done wrongly is not posted the relevant portions of your configurations. 🙂

  11. Here is the relevant portion of the config;

    ASA

    ASA G0/1-SW G0/24

    interface GigabitEthernet0/1
    description Connection-CORE-SWITCH
    nameif inside
    security-level 100
    ip address 172.16.1.1 255.255.255.0

    router ospf 1
    network 172.16.1.0 255.255.255.0 area 0

    CORE SWITCH

    interface GigabitEthernet0/24
    description Connection-to-ASA
    switchport access vlan 10
    switchport mode access
    !

    interface Vlan10
    description DEVICES
    ip address 172.16.1.2 255.255.255.0
    !
    interface Vlan20
    description LAN
    ip address 172.16.2.2 255.255.255.0
    !
    interface Vlan30
    description WIRELESS-USERS
    ip address 172.16.3.2 255.255.255.0

    router ospf 1
    network 172.16.1.0 0.0.0.255 area 0
    network 172.16.2.0 0.0.0.255 area 0
    network 172.16.3.0 0.0.0.255 area 0

    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 172.16.1.2

  12. One thing that comes to mind looking at your configs is the SVIs states. Are those virtual interfaces truly up/up. Remember, they will need active physical interfaces participating in them or they do not come up.

    1. Yes the svi’s are up.I connected two pc’s on the vlan access ports.
      I also tried eigrp and got same result. ASA version is 9.3 on 5512-x and switch is 3560-cx ios15.2
      It’s strange as I have done this several times and it worked without issues on different boxes.

  13. Hi Anthony,

    I am putting all gear together to start the CCIE prep. I have been a CCNA since 2006 and CCNP since 2014. So, these are the questions:
    • Which books do you recommend? I already have the CCIE Routing and Switching v5.0 Official Cert Guide, Volume 1 and 2, 5th Edition.
    • Is the standard version of VIRL enough for the CCIE? I see it only supports up to 15 Cisco devices. The troubleshooting session may have up to around 30. Do I really need that many? If so, I was thinking on using VIRL and actual devices.

    Thanks,
    YC

    1. A Safari Books Online subscription is what I now recommend. For each topic – you can search the entire Cisco Press library until you find what you are looking for. With that, and the DOC-CD online (free), you have all the documentation you need.

      Your 15 Cisco devices in VIRL is plenty to practice all the topics. When you are ready for some practice (mock) labs, you can rent.

  14. Just to add, I have purchased cisco Virl and I’m a bit disappointed with what I got. I have 16gb memory on my laptop, Intel core i7. I allocated 10gb ram to virl on VMware workstation but I have not been able to run 15 devices. You should read the memory requirment properly before investing in virl. If you want to combine iosv and iosl2v, I’m not sure you can run up to 8 devices with 10gb ram in Virl. This is not well documented. Also, you need Internet access any time you need to run virl else you won’t be able to run a lab.

    1. Hey John!

      Just wanted to clarify a point you made that I do not think is correct. You do not need Internet access every time you run VIRL. You get a grace period of 7 days (off the top of my head I think that is the duration) where VIRL does not need to check in with Internet-based registration servers. Once you check in with them – that grace resets.

      Thanks again for your feedback, I just wanted to make sure we are accurate on all points.

      1. Once again this was why I said the documentation is misleading. You need internet access to connect to virl each time you need to run a lab. I have tried this a number of time and I can’t get VM Maestro to connect to openstack each time I boot up my computer without connecting to the internet. I keep getting openstack connection error when I try to use vm maestro but immediately I connect to the internet, the error disappears.
        Just to add that you only need internet for virl to communicate with the salt server whenever you need to use virl after a reboot. You can keep using virl without internet after the initial communication but you will need internet access again if you reboot your pc.
        The 7days grace period does not apply here as this is only for the license validation and I don’t understand why they keep promoting this when you cannot run virl without internet.
        I have even seen this question asked in virl community but no one has responded as the documentation states that you need regular access to the internet to use virl. Anthony, please verify this claim and get back to us.

        1. Hi John!

          Thanks again for this valuable information. I totally have always believed their docs and just realized I never tried it. Sure enough – no joy without the Internet. I will be hanging out with the VIRL engineers next week at Cisco Live and will get to the bottom of this.

  15. Thank you so much for sharing that – I am on a brand new 32 GB RAM iMac with the latest VIRL and it screams – but this might not be such a realistic platform for many students.

    1. How can I run a Term Emulator (i.e. Putty) with VIRL running vSphere Client. I can find documentation for Windows and Mac, that’s it.

      Thanks,

      YC

  16. Is there any way to capture packets in VIRL using Wire-shark, for instance? I read about exporting the files to a server as in a real environment. That’s sounds to slow for educational purposes.

    YC

    1. There is now an integrated packet capture feature. I have not played with it yet – but they demonstrate it in one of the VIRL Webinars. If you want to check those out – they are on the VIRL channel in YouTube.

Leave a Reply

Your email address will not be published.